VIPM Dependencies are not installable

Question

I’m trying to install the package: aj_lv_ftdi_driver_for_i2c_spi_gpio-1.0.0.31.vipevaluation version downloaded from http://www.ni.com/gate/gb/GB_EVALTLKTFTDII2CGPIOAJ/US
There is a list of dependencies that are not available to install:

image.png

In the end, I get the following Error code 66 message from VIPM

image.png

Solution

For some reason, when installing aj_lv_ftdi_driver_for_i2c_spi_gpio-1.0.0.31.vip with VIPM there are OpenG dependencies that are not able to install them.

image.png

Install the oglib_file and oglib_lvzip independently on VIPM. For downloading the OpenG libraries, a few links are:

Alternatively, solution worked for other customer is as follows

Go to a computer that has OpenG already installed.  Go to the C:\ProgramData\JKI\VIPM\cache folder, copy all the OpenG package files to the offline computer via USB. Install everything manually then re-try to install aj_lv_ftdi_driver_for_i2c_spi_gpio-1.0.0.31.vip

image.png

Ajay is a professional developer and architect of LabVIEW applications with extreme interest in getting the hardware connected to LabVIEW and automate the stuffs.  He is also a good mentor for the various interns in his career.  He is ready to help the people in techie roles.

Leave a Reply

Your email address will not be published. Required fields are marked *